Q1:通达信大盘分时图中的红绿柱没有了怎么添加?

你试下Ctrl+D,打开系统设置---设置4:
钩选“大盘显示领先图”,确认。

Q2:通达信红绿柱变粗后 在下面公式里 每一根红柱顶上出现红色数字 1 2 3 4...到红柱消失 绿柱底...

{金叉}
DIF:EMA(CLOSE,9)-EMA(CLOSE,18);
DEA:EMA(DIF,7),LINETHICK1;
MACD:=2*(DIF-DEA);
STICKLINE(MACD>=0,MACD,0,0,0),COLORF00FF0;
STICKLINE(MACD<0,MACD,0,0,0),COLORF00FF0;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0,0 ),COLORFFFF00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0,0 ),COLORFFFF00;
IF(DIF<0,DIF,0),COLORRED,LINETHICK1;
IF(DIF<0,0,DIF),COLORRED,LINETHICK1;
IF(DIF<DEA,DIF,DEA),COLOR00FF00,LINETHICK1;
IF(DIF>DEA,DEA,DEA),COLORWHITE,LINETHICK1;
金叉:=CROSS(DIF,DEA) AND DIF<0.3;
STICKLINE(金叉,0,-0.38,3,0),COLOR0000FF;

Q3:怎么查看以前带红绿柱的大盘分时图 通达信只有当天的才有红绿柱

【以前带红绿柱的大盘分时图】,恩,明白。
那是设置的问题。
摁CTRL+D→设置4→右面第三个选项打钩
然后想看以前某一日的分时图,点那一日的一下,回车。就这样。

Q4:怎样修改公式把通达信MACD红绿柱变粗?

参数还是MACD原来的参数,保持不变,你自己重新输入。
新公式1 如下:
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIF,MID);
MACD:(DIF-DEA)*2,COLORSTICK;
STICKLINE(DIF>DEA,MACD,0,1,0),COLOR0000FF;
STICKLINE(DIF<DEA,MACD,0,1,0),COLOR008000;
STICKLINE(DIF=DEA,MACD,0,1,0),COLOR000000;
如果希望更粗的话,公式2 如下:
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIF,MID);
MACD:(DIF-DEA)*2,COLORSTICK;
STICKLINE(DIF>DEA,MACD,0,2,0),COLOR0000FF;
STICKLINE(DIF<DEA,MACD,0,2,0),COLOR008000;
STICKLINE(DIF=DEA,MACD,0,2,0),COLOR000000;
{ 把以上你满意的任一个公式直接粘贴到新公式中 或 覆盖原来的MACD公式也行,我已检测过,没有问题,希望能达到你的要求。 }

Q5:macd的红柱和绿柱是如何算计算的?

MACD指标的计算方法
MACD在应用上,首先计算出快速移动平均线(即EMA1)和慢速移动平均线(即EMA2),以此两个数值,来作为测量两者(快慢速线)间的离差值(DIF)的依据,然后再求DIF的N周期的平滑移动平均线DEA(也叫MACD、DEM)线。
以EMA1的参数为12日,EMA2的参数为26日,DIF的参数为9日为例来看看MACD的计算过程
1、计算移动平均值(EMA)
12日EMA的算式为
EMA(12)=前一日EMA(12)×11/13+今日收盘价×2/13
26日EMA的算式为
EMA(26)=前一日EMA(26)×25/27+今日收盘价×2/27
2、计算离差值(DIF)
DIF=今日EMA(12)-今日EMA(26)
3、计算DIF的9日EMA
根据离差值计算其9日的EMA,即离差平均值,是所求的MACD值。为了不与指标原名相混淆,此值又名DEA或DEM。
今日DEA(MACD)=前一日DEA×8/10+今日DIF×2/10
计算出的DIF和DEA的数值均为正值或负值。
理论上,在持续的涨势中,12日EMA线在26日 EMA线之上,其间的正离差值(+DIF)会越来越大;反之,在跌势中离差值可能变为负数(—DIF),也会越来越大,而在行情开始好转时,正负离差值将会缩小。指标MACD正是利用正负的离差值(±DIF)与离差值的N日平均线(N日EMA)的交叉信号作为买卖信号的依据,即再度以快慢速移动线的交叉原理来分析买卖信号。另外,MACD指标在股市软件上还有个辅助指标——BAR柱状线,其公式为:BAR=2×(DIF-DEA),我们还是可以利用BAR柱状线的收缩来决定买卖时机。
离差值DIF和离差平均值DEA是研判MACD的主要工具。其计算方法比较烦琐,由于目前这些计算值都会在股市分析软件上由计算机自动完成,因此,投资者只要了解其运算过程即可,而更重要的是掌握它的研判功能。另外,和其他指标的计算一样,由于选用的计算周期的不同,MACD指标也包括日MACD指标、周MACD指标、月MACD指标年MACD指标以及分钟MACD指标等各种类型。经常被用于股市研判的是日MACD指标和周MACD指标。虽然它们的计算时的取值有所不同,但基本的计算方法一样。
在实践中,将各点的 DIF和DEA(MACD)连接起来就会形成在零轴上下移动的两条快速(短期)和慢速(长期)线

Q6:MACD 判断时,到底是看红绿柱子的长短,还是看红绿柱子

MACD主要是看金叉、死叉,还有顶背离和底背离的!